BMW Fault code 2A98 Crank Shaft, Cam Shaft Correlation Faulty

This Crank Shaft, Camshaft Correlation fault would set a check engine light and could cause some rough running. This video shows the failure for this fault code and gives a desription of some other reasons this fault may set and some common and not so common examples are noted.

Comments

AskTheCarExperts: You might want to start by replacing the VANOS solenoids. If it comes back you need to check the vanos units. They come as an assembly. Timing tools are needed for this repair.

AskTheCarExperts: Bună ziua, fix a fost de a înlocui unitățile VANOS.Momentul motor trebuie să fie stabilite atunci când înlocuiți unitățile. Sper că acest lucru vă ajută. Sunt folosind Google Translator pentru a posta la tine.

AskTheCarExperts: Sweet! When we change these at work we often sell an oil change as well. Even BMW recomends this for some situations and was a great idea to try. If the port is clogged it can definately set the faults as the VANOS would not be working correctly with low oil pressure. Very nice!

Costin Cristescu: Hello again , I think I have solved the problem ( no error code , engine good working , Inpa parammeters ok ) I had done a flush + an oil change / replace intake solenoid + both non-return valves (code 11367541692) fron the cyl .head ( found clogged with sludge) So I think the real problem comes from the dirty oil / sludge in engine ( I had compare the resitances of the old solenoids with new one and was the same...)

AskTheCarExperts: If the swap resulted in the same codes this could be the VANOS unit or the hook ring seals. Timing tools are needed if you need the VANOS unit replaced if the pick up is not correctly seated due to the spring. If the VANOS units look normal then the hook ring seal on the intake side needs to be checked and the bearing ledge checked for a groove which results in a loss of oil pressure which can cause this fault as well.

Costin Cristescu: My last VIN is CC99090 (525Ix N52 '05) . I have the errors 2a82 + 2a98 (inlet vanos mechanicaly jammed bla bla ) + rough idle +MIL light . I had switched the solenoids - after cleaning both of them with service air - and no change - more over I have same value in INPA - nothing changed in parameters / same errors ...I mention that I had done an adaption reset many times .I am out of any logical ideas...Any way i wil replace the solenoid + an oil change

Costin Cristescu: My last VIN is CC99090 (525Ix N52 '05) . I have the errors 2a82 + 2a98 (inlet vanos mechanicaly jammed bla bla ) + rough idle +MIL light . I had switched the solenoids - after cleaning both of them with service air - and no change - more over I have same value in INPA - nothing changed in parameters / same errors ...I mention that I had done an adaption reset many times .

AskTheCarExperts: Hello Costin, Can you post the last seven of your VIN and describe the problem and fasult codes. I might be able to help.

Costin Cristescu: Good video but I think you cut the best part...I want to see the differences between the bad spring an the good spring... I mean the spring shouldn't move like this ? Should be fixed in position ? Sorry for my questions but I never seen an open head ...and I have a Vanos inlet problem.

AskTheCarExperts: Hello, Actually the same thing happened to one of my techs. He had damaged the crank shaft sensor while doing the starter and damaged a fuse in the E-box. Do you have any specific fault codes that are setting? If I know the codes I might be able to help.

silvestre2381: Car was turned on again and BOOM limp mode again. My mechanic told me that the throttle was bad. He checked it but it was OK. He did a lot of test and nothing. Could this be a vanos problem or something related? Sorry for my English.

silvestre2381: Hi! I have a BMW E90 2006 with an strange problem. I had a starter failure, when the starter was replaced at the same time spark plugs and oil cover gasket was replaced too. When the car was turned on the car went into a limp mode. They erased code errors that had and the car suddenly didn't have acceleration problems.

Your name:

Your comment: